BizTalk Server Tutorial

BizTalk Server Concepts and Common Errors

Issue: Schema not found in BizTalk Type Picker of a BizTalk Map

Today I had a different issue when in I started to work on a BizTalk Sample created by a colleague.
It has a source and destination schema, which are to be mapped.

A new map is then created and a source schema is added. When I clicked on Select Destination Schema, I was not able to find the destination schema in the BizTalk Type Picker of the BizTalk Map.

There are no build errors and every thing looked fine.

The culprit which led to this is the Build Action property of the schema.

This property will be shown when you select the schema in the Solution Explorer.

If this property is set to None, it will not be included in the Build and hence will not be able to use that in BizTalk Tools.

I made the Build Action to BTSCompile and it showed up in the BizTalk Type Picker of the BizTalk Map.

The reason being for this is that the schema was not created using BizTalk Schema Editor rather using an external tool. Hence when this schema was imported to BizTalk Project, its Build Action property was set to None.

So, care should be taken for the schemas that are created outside BizTalk Schema Editor.

Hope it helps.

– Shiv

Web Counters

December 4, 2010 - Posted by | Common Errors & Solutions, Maps | , ,

2 Comments »

  1. very useful article.thanks to share with us : )

    Comment by Anonymous | September 3, 2013 | Reply

  2. Very Good one….

    Comment by Sleepy | January 16, 2011 | Reply


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: